This is the system status for Shreejee Electronics' service, network and process. Real-time status and incident history are available here.

Courier Service Delays - FedEx

Resolved
Major outage
Started over 2 years ago Lasted 21 days

Affected

Order Fulfillment
Shipping and Transportation
Updates
  • Resolved
    Resolved

    All backlogs have been delivered and new carrier partners are deployed.

  • Monitoring
    Monitoring

    We have identified new shipping carriers and currently monitoring the result.

  • Identified
    Identified

    FedEx Logo FedEx is experiencing substantial disruptions to its Indian services due handover of its operations to Delhivery Ltd. Potential delays are possible for our order deliveries across India as we continue to work out with new transporters.

    More information on our blog.

  • Investigating
    Investigating

    Delays in the final delivery of orders by our carrier partners. Mitigations are being deployed.